ecl-screamer
Nondeterministic programming and constraint propagation
Screamer is an extension of Common Lisp that adds support for nondeterministic programming. Screamer consists of two levels. The basic nondeterministic level adds support for backtracking and undoable side effects. On top of this nondeterministic substrate, Screamer provides a comprehensive constraint programming language in which one can formulate and solve mixed systems of numeric and symbolic constraints. Together, these two levels augment Common Lisp with practically all of the functionality of both Prolog and constraint logic programming languages such as CHiP and CLP(R). Furthermore, Screamer is fully integrated with Common Lisp. Screamer programs can coexist and interoperate with other extensions to as CLIM and Iterate.
- Versions: 0.0.1-1.ce50614
- Website: https://nikodemus.github.io/screamer/
- Licenses: Expat
- Package source: gnu/packages/lisp-xyz.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of ecl-screamer
as follows:
guix install ecl-screamer
Or install a particular version:
guix install ecl-screamer@0.0.1-1.ce50614
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.
Badge code
You can use the following badge to inform users of ecl-screamer about the latest version available in Guix.
Example HTML:
<a href='https://packages.guix.gnu.org/packages/ecl-screamer'><img src='https://packages.guix.gnu.org/packages/ecl-screamer/badges/latest-version.svg' alt='Version in GNU Guix'></a>
Example Markdown:
[![Version in GNU Guix](https://packages.guix.gnu.org/packages/ecl-screamer/badges/latest-version.svg)](https://packages.guix.gnu.org/packages/ecl-screamer)
Example Org:
[[https://packages.guix.gnu.org/packages/ecl-screamer][https://packages.guix.gnu.org/packages/ecl-screamer/badges/latest-version.svg]]