gdb
The GNU debugger
GDB is the GNU debugger. With it, you can monitor what a program is doing while it runs or what it was doing just before a crash. It allows you to specify the runtime conditions, to define breakpoints, and to change how the program is running to try to fix bugs. It can be used to debug programs written in C, C++, Ada, Objective-C, Pascal and more.
- Versions: 12.1
- Website: https://www.gnu.org/software/gdb/
- Licenses: GPL 3+
- Package source: gnu/packages/gdb.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of gdb
as follows:
guix install gdb
Or install a particular version:
guix install gdb@12.1
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.