ghc-basic-prelude
Enhanced core prelude; a common foundation for alternate preludes
The premise of basic-prelude is that there are a lot of very commonly desired features missing from the standard Prelude, such as commonly used operators (<$> and >=>, for instance) and imports for common datatypes (e.g., ByteString and Vector). At the same time, there are lots of other components which are more debatable, such as providing polymorphic versions of common functions.
So basic-prelude is intended to give a common foundation for a number of alternate preludes. The package provides two modules: CorePrelude provides the common ground for other preludes to build on top of, while BasicPrelude exports CorePrelude together with commonly used list functions to provide a drop-in replacement for the standard Prelude.
Users wishing to have an improved Prelude can use BasicPrelude. Developers wishing to create a new prelude should use CorePrelude.
- Versions: 0.7.0
- Website: https://github.com/snoyberg/basic-prelude#readme
- Licenses: Expat
- Package source: gnu/packages/haskell-xyz.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of ghc-basic-prelude
as follows:
guix install ghc-basic-prelude
Or install a particular version:
guix install ghc-basic-prelude@0.7.0
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.
Badge code
You can use the following badge to inform users of ghc-basic-prelude about the latest version available in Guix.
Example HTML:
<a href='https://packages.guix.gnu.org/packages/ghc-basic-prelude'><img src='https://packages.guix.gnu.org/packages/ghc-basic-prelude/badges/latest-version.svg' alt='Version in GNU Guix'></a>
Example Markdown:
[](https://packages.guix.gnu.org/packages/ghc-basic-prelude)
Example Org:
[[https://packages.guix.gnu.org/packages/ghc-basic-prelude][https://packages.guix.gnu.org/packages/ghc-basic-prelude/badges/latest-version.svg]]