This package browser is in early development. Mind the rough edges.

git-tools

Assorted git-related scripts and tools

git-tools is a collection of bash and python scripts. Specifically, it includes the following tools:

  • git-branches-rename: Batch rename branches with a matching prefix to another prefix

  • git-clone-subset: Clone a subset of a git repository

  • git-find-uncommitted-repos: Recursively list repositories in the given directory(ies) that have uncommitted changes

  • git-rebase-theirs: Resolve rebase conflicts and failed cherry-picks by favoring "theirs" version

  • git-restore-mtime: Restore modification time of files based on the date of the most recent commit that modified them

  • git-strip-merge: A git-merge wrapper that deletes files on a "foreign" branch before merging

Installation

Install the latest version of git-tools as follows:

guix install git-tools

Or install a particular version:

guix install git-tools@2022.12

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.

Badge code

You can use the following badge to inform users of git-tools about the latest version available in Guix.

Example HTML:

<a href='https://packages.guix.gnu.org/packages/git-tools'><img src='https://packages.guix.gnu.org/packages/git-tools/badges/latest-version.svg' alt='Version in GNU Guix'></a>

Example Markdown:

[![Version in GNU Guix](https://packages.guix.gnu.org/packages/git-tools/badges/latest-version.svg)](https://packages.guix.gnu.org/packages/git-tools)

Example Org:

[[https://packages.guix.gnu.org/packages/git-tools][https://packages.guix.gnu.org/packages/git-tools/badges/latest-version.svg]]