go
Compiler and libraries for Go, a statically-typed language
Go, also commonly referred to as golang, is an imperative programming language designed primarily for systems programming. Go is a compiled, statically typed language in the tradition of C and C++, but adds garbage collection, various safety features, and concurrent programming features in the style of communicating sequential processes (CSP).
- Versions: 1.4-bootstrap-20171003 · 1.23.2 · 1.22.7 · 1.21.5 · 1.20.2 · 1.19.7 · 1.18.10 · 1.17.13 · 1.16.15
- Website: https://go.dev/
- Licenses: Modified BSD
- Package source: gnu/packages/golang.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of go
as follows:
guix install go
Or install a particular version:
guix install go@1.16.15
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.
Badge code
HTML: <a href='http://127.0.0.1:3000/packages/go/'><img src='http://127.0.0.1:3000/packages/go/badges/latest-version.svg'></img></a> Markdown: [![GNU Guix](http://127.0.0.1:3000/packages/go/badges/latest-version.svg)](http://127.0.0.1:3000/packages/go/) Org: [[http://127.0.0.1:3000/packages/go/][http://127.0.0.1:3000/packages/go/badges/latest-version.svg]]