This package browser is in early development. Mind the rough edges.

go-golang-org-x-sync

Additional Go concurrency primitives

This package provides Go concurrency primitives in addition to the ones provided by the language and sync and sync/atomic packages. The package provides several Golang submodules:

  • errgroup - synchronization, error propagation, and Context cancellation for groups of goroutines working on subtasks of a common task

  • semaphore - a weighted semaphore implementation

  • singleflight - a duplicate function call suppression mechanism

  • syncmap - a concurrent map implementation

Installation

Install the latest version of go-golang-org-x-sync as follows:

guix install go-golang-org-x-sync

Or install a particular version:

guix install go-golang-org-x-sync@0.10.0

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.

Badge code

You can use the following badge to inform users of go-golang-org-x-sync about the latest version available in Guix.

Example HTML:

<a href='https://packages.guix.gnu.org/packages/go-golang-org-x-sync'><img src='https://packages.guix.gnu.org/packages/go-golang-org-x-sync/badges/latest-version.svg' alt='Version in GNU Guix'></a>

Example Markdown:

[![Version in GNU Guix](https://packages.guix.gnu.org/packages/go-golang-org-x-sync/badges/latest-version.svg)](https://packages.guix.gnu.org/packages/go-golang-org-x-sync)

Example Org:

[[https://packages.guix.gnu.org/packages/go-golang-org-x-sync][https://packages.guix.gnu.org/packages/go-golang-org-x-sync/badges/latest-version.svg]]