java-asm
Very small and fast Java bytecode manipulation framework
ASM is an all purpose Java bytecode manipulation and analysis framework. It can be used to modify existing classes or dynamically generate classes, directly in binary form. The provided common transformations and analysis algorithms allow easily assembling custom complex transformations and code analysis tools.
- Versions: 9.4 · 8.0.1 · 6.0 · 3.1
- Website: https://asm.ow2.io/
- Licenses: Modified BSD
- Package source: gnu/packages/java.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of java-asm
as follows:
guix install java-asm
Or install a particular version:
guix install java-asm@3.1
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.
Badge code
HTML: <a href='http://127.0.0.1:3000/packages/java-asm/'><img src='http://127.0.0.1:3000/packages/java-asm/badges/latest-version.svg'></img></a> Markdown: [![GNU Guix](http://127.0.0.1:3000/packages/java-asm/badges/latest-version.svg)](http://127.0.0.1:3000/packages/java-asm/) Org: [[http://127.0.0.1:3000/packages/java-asm/][http://127.0.0.1:3000/packages/java-asm/badges/latest-version.svg]]