This package browser is in early development. Mind the rough edges.

java-commons-cli

Command line arguments and options parsing library

The Apache Commons CLI library provides an API for parsing command line options passed to programs. It is also able to print help messages detailing the options available for a command line tool.

Commons CLI supports different types of options:

  • POSIX like options (ie. tar -zxvf foo.tar.gz)

  • GNU like long options (ie. du --human-readable --max-depth=1)

  • Java like properties (ie. java -Djava.awt.headless=true Foo)

  • Short options with value attached (ie. gcc -O2 foo.c)

  • long options with single hyphen (ie. ant -projecthelp)

This is a part of the Apache Commons Project.

Installation

Install the latest version of java-commons-cli as follows:

guix install java-commons-cli

Or install a particular version:

guix install java-commons-cli@1.2

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.

Badge code

You can use the following badge to inform users of java-commons-cli about the latest version available in Guix.

Example HTML:

<a href='https://packages.guix.gnu.org/packages/java-commons-cli'><img src='https://packages.guix.gnu.org/packages/java-commons-cli/badges/latest-version.svg' alt='Version in GNU Guix'></a>

Example Markdown:

[![Version in GNU Guix](https://packages.guix.gnu.org/packages/java-commons-cli/badges/latest-version.svg)](https://packages.guix.gnu.org/packages/java-commons-cli)

Example Org:

[[https://packages.guix.gnu.org/packages/java-commons-cli][https://packages.guix.gnu.org/packages/java-commons-cli/badges/latest-version.svg]]