java-guava
Google core libraries for Java
Guava is a set of core libraries that includes new collection types (such as multimap and multiset), immutable collections, a graph library, functional types, an in-memory cache, and APIs/utilities for concurrency, I/O, hashing, primitives, reflection, string processing, and much more!
- Versions: 31.1
- Website: https://github.com/google/guava
- Licenses: ASL 2.0
- Package source: gnu/packages/java.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of java-guava
as follows:
guix install java-guava
Or install a particular version:
guix install java-guava@31.1
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.