java-la4j
Java library that provides Linear Algebra primitives and algorithms
The la4j library is a Java library that provides Linear Algebra primitives (matrices and vectors) and algorithms. The key features of the la4j library are:
No dependencies and tiny size
Fluent object-oriented/functional API
Sparse (CRS, CCS) and dense (1D/2D arrays) matrices
Linear systems solving (Gaussian, Jacobi, Zeidel, Square Root, Sweep and other)
Matrices decomposition (Eigenvalues/Eigenvectors, SVD, QR, LU, Cholesky and other)
MatrixMarket/CSV IO formats support for matrices and vectors
- Versions: 0.6.0
- Website: http://la4j.org/
- Licenses: ASL 2.0
- Package source: gnu/packages/algebra.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of java-la4j
as follows:
guix install java-la4j
Or install a particular version:
guix install java-la4j@0.6.0
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.
Badge code
HTML: <a href='http://127.0.0.1:3000/packages/java-la4j/'><img src='http://127.0.0.1:3000/packages/java-la4j/badges/latest-version.svg'></img></a> Markdown: [![GNU Guix](http://127.0.0.1:3000/packages/java-la4j/badges/latest-version.svg)](http://127.0.0.1:3000/packages/java-la4j/) Org: [[http://127.0.0.1:3000/packages/java-la4j/][http://127.0.0.1:3000/packages/java-la4j/badges/latest-version.svg]]