This package browser is in early development. Mind the rough edges.

java-xerces 2.12.1

Validating XML parser for Java with DOM level 3 support

The Xerces2 Java parser is the reference implementation of XNI, the Xerces Native Interface, and also a fully conforming XML Schema processor.

Xerces2-J supports the following standards and APIs:

  • eXtensible Markup Language (XML) 1.0 Second Edition Recommendation

  • Namespaces in XML Recommendation

  • Document Object Model (DOM) Level 2 Core, Events, and Traversal and Range Recommendations

  • Simple API for XML (SAX) 2.0.1 Core and Extension

  • Java APIs for XML Processing (JAXP) 1.2.01

  • XML Schema 1.0 Structures and Datatypes Recommendations

  • Experimental implementation of the Document Object Model (DOM) Level 3 Core and Load/Save Working Drafts

  • Provides a partial implementation of the XML Inclusions (XInclude) W3C Candidate Recommendation

Xerces is now able to parse documents written according to the XML 1.1 Candidate Recommendation, except that it does not yet provide an option to enable normalization checking as described in section 2.13 of this specification. It also handles namespaces according to the XML Namespaces 1.1 Candidate Recommendation, and will correctly serialize XML 1.1 documents if the DOM level 3 load/save API's are in use.

Installation

Install java-xerces 2.12.1 as follows:

guix install java-xerces@2.12.1

Or install the latest version:

guix install java-xerces

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.