This package browser is in early development. Mind the rough edges.

kitemmodels

Set of item models extending the Qt model-view framework

KItemModels provides the following models:

  1. KBreadcrumbSelectionModel - Selects the parents of selected items to create breadcrumbs.

  2. KCheckableProxyModel - Adds a checkable capability to a source model.

  3. KConcatenateRowsProxyModel - Concatenates rows from multiple source models.

  4. KDescendantsProxyModel - Proxy Model for restructuring a Tree into a list.

  5. KExtraColumnsProxyModel - Adds columns after existing columns.

  6. KLinkItemSelectionModel - Share a selection in multiple views which do not have the same source model.

  7. KModelIndexProxyMapper - Mapping of indexes and selections through proxy models.

  8. KRearrangeColumnsProxyModel - Can reorder and hide columns from the source model.

  9. KRecursiveFilterProxyModel - Recursive filtering of models.

  10. KSelectionProxyModel - A Proxy Model which presents a subset of its source model to observers

Installation

Install the latest version of kitemmodels as follows:

guix install kitemmodels

Or install a particular version:

guix install kitemmodels@5.116.0

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.

Badge code

You can use the following badge to inform users of kitemmodels about the latest version available in Guix.

Example HTML:

<a href='https://packages.guix.gnu.org/packages/kitemmodels'><img src='https://packages.guix.gnu.org/packages/kitemmodels/badges/latest-version.svg' alt='Version in GNU Guix'></a>

Example Markdown:

[![Version in GNU Guix](https://packages.guix.gnu.org/packages/kitemmodels/badges/latest-version.svg)](https://packages.guix.gnu.org/packages/kitemmodels)

Example Org:

[[https://packages.guix.gnu.org/packages/kitemmodels][https://packages.guix.gnu.org/packages/kitemmodels/badges/latest-version.svg]]