kitemmodels
Set of item models extending the Qt model-view framework
KItemModels provides the following models:
KBreadcrumbSelectionModel - Selects the parents of selected items to create breadcrumbs.
KCheckableProxyModel - Adds a checkable capability to a source model.
KConcatenateRowsProxyModel - Concatenates rows from multiple source models.
KDescendantsProxyModel - Proxy Model for restructuring a Tree into a list.
KExtraColumnsProxyModel - Adds columns after existing columns.
KLinkItemSelectionModel - Share a selection in multiple views which do not have the same source model.
KModelIndexProxyMapper - Mapping of indexes and selections through proxy models.
KRearrangeColumnsProxyModel - Can reorder and hide columns from the source model.
KRecursiveFilterProxyModel - Recursive filtering of models.
KSelectionProxyModel - A Proxy Model which presents a subset of its source model to observers
- Versions: 6.5.0 · 5.116.0
- Website: https://community.kde.org/Frameworks
- Licenses: LGPL 2.1+
- Package source: gnu/packages/kde-frameworks.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of kitemmodels
as follows:
guix install kitemmodels
Or install a particular version:
guix install kitemmodels@5.116.0
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.
Badge code
You can use the following badge to inform users of kitemmodels about the latest version available in Guix.
Example HTML:
<a href='https://packages.guix.gnu.org/packages/kitemmodels'><img src='https://packages.guix.gnu.org/packages/kitemmodels/badges/latest-version.svg' alt='Version in GNU Guix'></a>
Example Markdown:
[](https://packages.guix.gnu.org/packages/kitemmodels)
Example Org:
[[https://packages.guix.gnu.org/packages/kitemmodels][https://packages.guix.gnu.org/packages/kitemmodels/badges/latest-version.svg]]