libffi
Foreign function call interface library
The libffi library provides a portable, high level programming interface to various calling conventions. This allows a programmer to call any function specified by a call interface description at run-time.
FFI stands for Foreign Function Interface. A foreign function interface is the popular name for the interface that allows code written in one language to call code written in another language. The libffi library really only provides the lowest, machine dependent layer of a fully featured foreign function interface. A layer must exist above libffi that handles type conversions for values passed between the two languages.
- Versions: 3.4.4
- Website: https://www.sourceware.org/libffi/
- Licenses: Expat
- Package source: gnu/packages/libffi.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of libffi
as follows:
guix install libffi
Or install a particular version:
guix install libffi@3.4.4
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.
Badge code
You can use the following badge to inform users of libffi about the latest version available in Guix.
Example HTML:
<a href='https://packages.guix.gnu.org/packages/libffi'><img src='https://packages.guix.gnu.org/packages/libffi/badges/latest-version.svg' alt='Version in GNU Guix'></a>
Example Markdown:
[](https://packages.guix.gnu.org/packages/libffi)
Example Org:
[[https://packages.guix.gnu.org/packages/libffi][https://packages.guix.gnu.org/packages/libffi/badges/latest-version.svg]]