This package browser is in early development. Mind the rough edges.

libobjc2

Objective-C runtime library for Clang

Libobjc2 is an Objective-C runtime library designed as a drop-in replacement for GCC runtime. It supports following features beyond GCC runtime.

  • Modern Objective-C runtime APIs.

  • Blocks (Closures).

  • Synthesised property accessors.

  • Efficient support for @synchronized().

  • Type-dependent dispatch.

  • Associated reference API.

  • Automatic Reference Counting.

Installation

Install the latest version of libobjc2 as follows:

guix install libobjc2

Or install a particular version:

guix install libobjc2@2.1

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.