This package browser is in early development. Mind the rough edges.

llvm 14.0.6

Optimizing compiler infrastructure

LLVM is a compiler infrastructure designed for compile-time, link-time, runtime, and idle-time optimization of programs from arbitrary programming languages. It currently supports compilation of C and C++ programs, using front-ends derived from GCC 4.0.1. A new front-end for the C family of languages is in development. The compiler infrastructure includes mirror sets of programming tools as well as libraries with equivalent functionality.

Installation

Install llvm 14.0.6 as follows:

guix install llvm@14.0.6

Or install the latest version:

guix install llvm

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.