This package browser is in early development. Mind the rough edges.

mujs

JavaScript interpreter written in C

MuJS is a lightweight Javascript interpreter designed for embedding in other software to extend them with scripting capabilities. MuJS was designed with a focus on small size, correctness, and simplicity. It is written in portable C and implements ECMAScript as specified by ECMA-262. The interface for binding with native code is designed to be as simple as possible to use, and is very similar to Lua. There is no need to interact with byzantine C++ template mechanisms, or worry about marking and unmarking garbage collection roots, or wrestle with obscure build systems.

Installation

Install the latest version of mujs as follows:

guix install mujs

Or install a particular version:

guix install mujs@1.3.5

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.

Badge code

You can use the following badge to inform users of mujs about the latest version available in Guix.

Example HTML:

<a href='https://packages.guix.gnu.org/packages/mujs'><img src='https://packages.guix.gnu.org/packages/mujs/badges/latest-version.svg' alt='Version in GNU Guix'></a>

Example Markdown:

[![Version in GNU Guix](https://packages.guix.gnu.org/packages/mujs/badges/latest-version.svg)](https://packages.guix.gnu.org/packages/mujs)

Example Org:

[[https://packages.guix.gnu.org/packages/mujs][https://packages.guix.gnu.org/packages/mujs/badges/latest-version.svg]]