This package browser is in early development. Mind the rough edges.

neko 2.3.0

High-level dynamically typed programming language and virtual machine

The Neko programming language is a high-level dynamically typed programming language. It can be used as an embedded scripting language. It has been designed to provide a common runtime for several different languages. You can easily extend the language with C libraries. You can also write generators from your own language to Neko and then use the Neko Runtime to compile, run, and access existing libraries.

Neko has a compiler and a virtual machine. The Virtual Machine is both very lightweight and well optimized, so it can run very quickly. The VM can be easily embedded into any application and your libraries can be accessed using the C foreign function interface.

You can use the compiler as standalone command line executable separate from the VM, or as a Neko library to perform compile-and-run functions for interactive languages.

Installation

Install neko 2.3.0 as follows:

guix install neko@2.3.0

Or install the latest version:

guix install neko

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.