This package browser is in early development. Mind the rough edges.

node

Evented I/O for V8 JavaScript

Node.js is a platform built on Chrome's JavaScript runtime for easily building fast, scalable network applications. Node.js uses an event-driven, non-blocking I/O model that makes it lightweight and efficient, perfect for data-intensive real-time applications that run across distributed devices.

Installation

Install the latest version of node as follows:

guix install node

Or install a particular version:

guix install node@10.24.1

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.