This package browser is in early development. Mind the rough edges.

python

High-level, dynamically-typed programming language

Python is a remarkably powerful dynamic programming language that is used in a wide variety of application domains. Some of its key distinguishing features include: clear, readable syntax; strong introspection capabilities; intuitive object orientation; natural expression of procedural code; full modularity, supporting hierarchical packages; exception-based error handling; and very high level dynamic data types.

Installation

Install the latest version of python as follows:

guix install python

Or install a particular version:

guix install python@3.10.7

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.

Badge code

HTML: <a href='http://127.0.0.1:3000/packages/python/'><img src='http://127.0.0.1:3000/packages/python/badges/latest-version.svg'></img></a>
Markdown: [![GNU Guix](http://127.0.0.1:3000/packages/python/badges/latest-version.svg)](http://127.0.0.1:3000/packages/python/)
Org: [[http://127.0.0.1:3000/packages/python/][http://127.0.0.1:3000/packages/python/badges/latest-version.svg]]