This package browser is in early development. Mind the rough edges.

python-aioftp 0.22.3

FTP client/server for asyncio in Python

FTP client and server for asyncio (Python 3) Library implementing FTP protocol, both client and server for Python asyncio module.

Supported commands as client: USER, PASS, ACCT, PWD, CWD, CDUP, MKD, RMD, MLSD, MLST, RNFR, RNTO, DELE, STOR, APPE, RETR, TYPE, PASV, ABOR, QUIT, REST, LIST (as fallback).

Supported commands as server: USER, PASS, QUIT, PWD, CWD, CDUP, MKD, RMD, MLSD, LIST (non-standard), MLST, RNFR, RNTO, DELE, STOR, RETR, TYPE ("I" and "A"), PASV, ABOR, APPE, REST.

Installation

Install python-aioftp 0.22.3 as follows:

guix install python-aioftp@0.22.3

Or install the latest version:

guix install python-aioftp

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.