This package browser is in early development. Mind the rough edges.

python-apscheduler 3.10.4

Task scheduling library for Python

Advanced Python Scheduler (APScheduler) is a Python library that lets you schedule your Python code to be executed later, either just once or periodically.

You can add new jobs or remove old ones on the fly as you please. If you store your jobs in a database, they will also survive scheduler restarts and maintain their state. When the scheduler is restarted, it will then run all the jobs it should have run while it was offline.

Installation

Install python-apscheduler 3.10.4 as follows:

guix install python-apscheduler@3.10.4

Or install the latest version:

guix install python-apscheduler

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.