This package browser is in early development. Mind the rough edges.

python-astroid 2.11.7

Python source code base representation

python-astroid provides a common base representation of Python source code for projects such as pychecker, pyreverse, pylint, etc. It provides a compatible representation which comes from the _ast module. It rebuilds the tree generated by the builtin _ast module by recursively walking down the AST and building an extended ast. The new node classes have additional methods and attributes for different usages. They include some support for static inference and local name scopes. Furthermore, astroid builds partial trees by inspecting living objects.

Installation

Install python-astroid 2.11.7 as follows:

guix install python-astroid@2.11.7

Or install the latest version:

guix install python-astroid

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.