This package browser is in early development. Mind the rough edges.

python-autoflake

Removes unused imports and unused variables

autoflake removes unused imports and unused variables from Python code as reported by pyflakes.

By default, it only removes unused imports for modules that are part of the standard library. Removal of unused variables is also disabled by default. It also removes useless pass statements.

Installation

Install the latest version of python-autoflake as follows:

guix install python-autoflake

Or install a particular version:

guix install python-autoflake@1.3.1

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.