This package browser is in early development. Mind the rough edges.

python-bitarray

Efficient arrays of booleans

This package provides an object type which efficiently represents an array of booleans. Bitarrays are sequence types and behave very much like usual lists. Eight bits are represented by one byte in a contiguous block of memory. The user can select between two representations: little-endian and big-endian. All of the functionality is implemented in C. Methods for accessing the machine representation are provided. This can be useful when bit level access to binary files is required, such as portable bitmap image files. Also, when dealing with compressed data which uses variable bit length encoding, you may find this module useful.

Installation

Install the latest version of python-bitarray as follows:

guix install python-bitarray

Or install a particular version:

guix install python-bitarray@2.8.1

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.

Badge code

You can use the following badge to inform users of python-bitarray about the latest version available in Guix.

Example HTML:

<a href='https://packages.guix.gnu.org/packages/python-bitarray'><img src='https://packages.guix.gnu.org/packages/python-bitarray/badges/latest-version.svg' alt='Version in GNU Guix'></a>

Example Markdown:

[![Version in GNU Guix](https://packages.guix.gnu.org/packages/python-bitarray/badges/latest-version.svg)](https://packages.guix.gnu.org/packages/python-bitarray)

Example Org:

[[https://packages.guix.gnu.org/packages/python-bitarray][https://packages.guix.gnu.org/packages/python-bitarray/badges/latest-version.svg]]