This package browser is in early development. Mind the rough edges.

python-catalogue 2.0.7

Lightweight function registries for your library

"catalogue" is a tiny, zero-dependencies library that makes it easy to add function (or object) registries to your code. Function registries are helpful when you have objects that need to be both easily serializable and fully customizable. Instead of passing a function into your object, you pass in an identifier name, which the object can use to lookup the function from the registry. This makes the object easy to serialize, because the name is a simple string. If you instead saved the function, you'd have to use Pickle for serialization, which has many drawbacks.

Installation

Install python-catalogue 2.0.7 as follows:

guix install python-catalogue@2.0.7

Or install the latest version:

guix install python-catalogue

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.