This package browser is in early development. Mind the rough edges.

python-cbor2

Concise Binary Object Representation (CBOR) (de)serializer

This Python library provides encoding and decoding for the Concise Binary Object Representation (CBOR) (RFC 8949) serialization format. The specification is fully compatible with the original RFC 7049. Among its features are:

  • Simple API like the json or pickle modules.

  • Support many CBOR tags with stdlib objects.

  • Generic tag decoding.

  • Shared value references including cyclic references.

  • String references compact encoding with repeated strings replaced with indices.

  • Optional C module backend tested on big- and little-endian architectures.

  • Extensible tagged value handling using tag_hook and object_hook on decode and default on encode.

Installation

Install the latest version of python-cbor2 as follows:

guix install python-cbor2

Or install a particular version:

guix install python-cbor2@5.4.2.post1

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.

Badge code

You can use the following badge to inform users of python-cbor2 about the latest version available in Guix.

Example HTML:

<a href='https://packages.guix.gnu.org/packages/python-cbor2'><img src='https://packages.guix.gnu.org/packages/python-cbor2/badges/latest-version.svg' alt='Version in GNU Guix'></a>

Example Markdown:

[![Version in GNU Guix](https://packages.guix.gnu.org/packages/python-cbor2/badges/latest-version.svg)](https://packages.guix.gnu.org/packages/python-cbor2)

Example Org:

[[https://packages.guix.gnu.org/packages/python-cbor2][https://packages.guix.gnu.org/packages/python-cbor2/badges/latest-version.svg]]