python-celery
Distributed Task Queue
Celery is an asynchronous task queue/job queue based on distributed message passing. It is focused on real-time operation, but supports scheduling as well. The execution units, called tasks, are executed concurrently on a single or more worker servers using multiprocessing, Eventlet, or gevent. Tasks can execute asynchronously (in the background) or synchronously (wait until ready).
- Versions: 5.4.0
- Website: https://celeryproject.org
- Licenses: Modified BSD
- Package source: gnu/packages/python-xyz.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of python-celery
as follows:
guix install python-celery
Or install a particular version:
guix install python-celery@5.4.0
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.
Badge code
You can use the following badge to inform users of python-celery about the latest version available in Guix.
Example HTML:
<a href='https://packages.guix.gnu.org/packages/python-celery'><img src='https://packages.guix.gnu.org/packages/python-celery/badges/latest-version.svg' alt='Version in GNU Guix'></a>
Example Markdown:
[](https://packages.guix.gnu.org/packages/python-celery)
Example Org:
[[https://packages.guix.gnu.org/packages/python-celery][https://packages.guix.gnu.org/packages/python-celery/badges/latest-version.svg]]