This package browser is in early development. Mind the rough edges.

python-eventlet 0.33.3

Concurrent networking library for Python

Eventlet is a concurrent networking library for Python that allows you to change how you run your code, not how you write it. It uses epoll or libevent for highly scalable non-blocking I/O. Coroutines ensure that the developer uses a blocking style of programming that is similar to threading, but provide the benefits of non-blocking I/O. The event dispatch is implicit, which means you can easily use Eventlet from the Python interpreter, or as a small part of a larger application.

Installation

Install python-eventlet 0.33.3 as follows:

guix install python-eventlet@0.33.3

Or install the latest version:

guix install python-eventlet

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.