This package browser is in early development. Mind the rough edges.

python-gitpython 3.1.24

Python library for interacting with Git repositories

GitPython is a python library used to interact with Git repositories, high-level like git-porcelain, or low-level like git-plumbing.

It provides abstractions of Git objects for easy access of repository data, and additionally allows you to access the Git repository more directly using either a pure Python implementation, or the faster, but more resource intensive git command implementation.

Installation

Install python-gitpython 3.1.24 as follows:

guix install python-gitpython@3.1.24

Or install the latest version:

guix install python-gitpython

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.