This package browser is in early development. Mind the rough edges.

python-glob2 0.7

Extended Version of the python buildin glob module

This is an extended version of the Python built-in glob module which adds:

  • The ability to capture the text matched by glob patterns, and return those matches alongside the file names.

  • A recursive ** globbing syntax, akin for example to the globstar option of Bash.

  • The ability to replace the file system functions used, in order to glob on virtual file systems.

  • Compatible with Python 2 and Python 3 (tested with 3.3).

Glob2 currently based on the glob code from Python 3.3.1.

Installation

Install python-glob2 0.7 as follows:

guix install python-glob2@0.7

Or install the latest version:

guix install python-glob2

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.