python-globber
Library for string matching with glob patterns
Globber is a Python library for matching file names against glob patterns. In contrast to other glob-matching libraries, it matches arbitrary strings and doesn't require the matched names to be existing files. In addition, it supports the globstar **
operator to match an arbitrary number of path components.
- Versions: 0.2.1
- Website: https://github.com/asharov/globber
- Licenses: ASL 2.0
- Package source: gnu/packages/python-xyz.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of python-globber
as follows:
guix install python-globber
Or install a particular version:
guix install python-globber@0.2.1
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.
Badge code
You can use the following badge to inform users of python-globber about the latest version available in Guix.
Example HTML:
<a href='https://packages.guix.gnu.org/packages/python-globber'><img src='https://packages.guix.gnu.org/packages/python-globber/badges/latest-version.svg' alt='Version in GNU Guix'></a>
Example Markdown:
[](https://packages.guix.gnu.org/packages/python-globber)
Example Org:
[[https://packages.guix.gnu.org/packages/python-globber][https://packages.guix.gnu.org/packages/python-globber/badges/latest-version.svg]]