This package browser is in early development. Mind the rough edges.

python-mpi4py 3.1.4

Python bindings for the Message Passing Interface standard

MPI for Python (mpi4py) provides bindings of the Message Passing Interface (MPI) standard for the Python programming language, allowing any Python program to exploit multiple processors.

mpi4py is constructed on top of the MPI-1/MPI-2 specification and provides an object oriented interface which closely follows MPI-2 C++ bindings. It supports point-to-point and collective communications of any picklable Python object as well as optimized communications of Python objects (such as NumPy arrays) that expose a buffer interface.

Installation

Install python-mpi4py 3.1.4 as follows:

guix install python-mpi4py@3.1.4

Or install the latest version:

guix install python-mpi4py

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.