This package browser is in early development. Mind the rough edges.

python-natsort

Natural sorting for python and shell

Natsort lets you apply natural sorting on lists instead of lexicographical. If you use the built-in sorted method in python on a list such as [a20, a9, a1, a4, a10], it would be returned as [a1, a10, a20, a4, a9]. Natsort provides a function natsorted that identifies numbers and sorts them separately from strings. It can also sort version numbers, real numbers, mixed types and more, and comes with a shell command natsort that exposes this functionality in the command line.

Installation

Install the latest version of python-natsort as follows:

guix install python-natsort

Or install a particular version:

guix install python-natsort@7.1.1

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.

Badge code

You can use the following badge to inform users of python-natsort about the latest version available in Guix.

Example HTML:

<a href='https://packages.guix.gnu.org/packages/python-natsort'><img src='https://packages.guix.gnu.org/packages/python-natsort/badges/latest-version.svg' alt='Version in GNU Guix'></a>

Example Markdown:

[![Version in GNU Guix](https://packages.guix.gnu.org/packages/python-natsort/badges/latest-version.svg)](https://packages.guix.gnu.org/packages/python-natsort)

Example Org:

[[https://packages.guix.gnu.org/packages/python-natsort][https://packages.guix.gnu.org/packages/python-natsort/badges/latest-version.svg]]