python-paramiko
SSHv2 protocol library
Paramiko is a python implementation of the SSHv2 protocol, providing both client and server functionality. While it leverages a Python C extension for low level cryptography (PyCrypto), Paramiko itself is a pure Python interface around SSH networking concepts.
- Versions: 2.7.2
- Website: https://www.paramiko.org/
- Licenses: LGPL 2.1+
- Package source: gnu/packages/python-crypto.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of python-paramiko
as follows:
guix install python-paramiko
Or install a particular version:
guix install python-paramiko@2.7.2
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.
Badge code
HTML: <a href='http://127.0.0.1:3000/packages/python-paramiko/'><img src='http://127.0.0.1:3000/packages/python-paramiko/badges/latest-version.svg'></img></a> Markdown: [![GNU Guix](http://127.0.0.1:3000/packages/python-paramiko/badges/latest-version.svg)](http://127.0.0.1:3000/packages/python-paramiko/) Org: [[http://127.0.0.1:3000/packages/python-paramiko/][http://127.0.0.1:3000/packages/python-paramiko/badges/latest-version.svg]]