This package browser is in early development. Mind the rough edges.

python-paramiko

SSHv2 protocol library

Paramiko is a python implementation of the SSHv2 protocol, providing both client and server functionality. While it leverages a Python C extension for low level cryptography (PyCrypto), Paramiko itself is a pure Python interface around SSH networking concepts.

Installation

Install the latest version of python-paramiko as follows:

guix install python-paramiko

Or install a particular version:

guix install python-paramiko@2.7.2

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.