This package browser is in early development. Mind the rough edges.

python-pathlib 1.0.1

Object-oriented file system paths

Pathlib offers a set of classes to handle file system paths. It offers the following advantages over using string objects:

  1. No more cumbersome use of os and os.path functions. Everything can be done easily through operators, attribute accesses, and method calls.

  2. Embodies the semantics of different path types. For example, comparing Windows paths ignores casing.

  3. Well-defined semantics, eliminating any inconsistencies or ambiguities (forward vs. backward slashes, etc.).

Note: In Python 3.4, pathlib is now part of the standard library. For other Python versions please consider python-pathlib2 instead, which tracks the standard library module. This module (python-pathlib) isn't maintained anymore.

Installation

Install python-pathlib 1.0.1 as follows:

guix install python-pathlib@1.0.1

Or install the latest version:

guix install python-pathlib

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.