python-psycopg2-binary
PostgreSQL database adapter for Python
Psycopg is a PostgreSQL database adapter for the Python programming language. Its main features are the complete implementation of the Python DB API 2.0 specification and the thread safety (several threads can share the same connection). It was designed for heavily multi-threaded applications that create and destroy lots of cursors and make a large number of concurrent INSERT
s or UPDATE
s.
Psycopg 2 is mostly implemented in C as a libpq wrapper, resulting in being both efficient and secure. It features client-side and server-side cursors, asynchronous communication and notifications, COPY TO
/COPY FROM
support. Many Python types are supported out-of-the-box and adapted to matching PostgreSQL data types; adaptation can be extended and customized thanks to a flexible objects adaptation system.
Psycopg 2 is both Unicode and Python 3 friendly.
- Versions: 2.9.3
- Website: https://psycopg.org/
- Licenses: LGPL 3+
- Package source: gnu/packages/python-xyz.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of python-psycopg2-binary
as follows:
guix install python-psycopg2-binary
Or install a particular version:
guix install python-psycopg2-binary@2.9.3
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.
Badge code
You can use the following badge to inform users of python-psycopg2-binary about the latest version available in Guix.
Example HTML:
<a href='https://packages.guix.gnu.org/packages/python-psycopg2-binary'><img src='https://packages.guix.gnu.org/packages/python-psycopg2-binary/badges/latest-version.svg' alt='Version in GNU Guix'></a>
Example Markdown:
[](https://packages.guix.gnu.org/packages/python-psycopg2-binary)
Example Org:
[[https://packages.guix.gnu.org/packages/python-psycopg2-binary][https://packages.guix.gnu.org/packages/python-psycopg2-binary/badges/latest-version.svg]]