This package browser is in early development. Mind the rough edges.

python-pyftpdlib 1.5.7

Asynchronous and scalable Python FTP server library

The Python FTP server library provides a high-level interface to write efficient, scalable and asynchronous FTP servers with Python. It is the most complete RFC-959 FTP server implementation available for Python, and has the following traits:

  • It is lightweight, fast and scalable.

  • It uses the sendfile(2) system call for uploads.

  • It uses epoll, kqueue and select to handle concurrency asynchronously.

  • It supports FTPS (RFC-4217), IPv6 (RFC-2428), Unicode file names (RFC-2640) and MLSD/MLST commands (RFC-3659).

  • It has a flexible system of authorizers able to manage both virtual and real users.

Installation

Install python-pyftpdlib 1.5.7 as follows:

guix install python-pyftpdlib@1.5.7

Or install the latest version:

guix install python-pyftpdlib

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.