This package browser is in early development. Mind the rough edges.

python-pypdf2 1.26.0

Pure Python PDF toolkit

PyPDF2 is a pure Python PDF library capable of:

  1. extracting document information (title, author, …)

  2. splitting documents page by page

  3. merging documents page by page

  4. cropping pages

  5. merging multiple pages into a single page

  6. encrypting and decrypting PDF files

By being pure Python, it should run on any Python platform without any dependencies on external libraries. It can also work entirely on StringIO objects rather than file streams, allowing for PDF manipulation in memory. It is therefore a useful tool for websites that manage or manipulate PDFs.

Installation

Install python-pypdf2 1.26.0 as follows:

guix install python-pypdf2@1.26.0

Or install the latest version:

guix install python-pypdf2

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.