python-pytorch
Python library for tensor computation and deep neural networks
PyTorch is a Python package that provides two high-level features:
tensor computation (like NumPy) with strong GPU acceleration;
deep neural networks (DNNs) built on a tape-based autograd system.
You can reuse Python packages such as NumPy, SciPy, and Cython to extend PyTorch when needed.
Note: currently this package does not provide GPU support.
- Versions: 2.5.1 · 2.0.1
- Website: https://pytorch.org/
- Licenses: Modified BSD
- Package source: gnu/packages/machine-learning.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of python-pytorch
as follows:
guix install python-pytorch
Or install a particular version:
guix install python-pytorch@2.0.1
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.
Badge code
You can use the following badge to inform users of python-pytorch about the latest version available in Guix.
Example HTML:
<a href='https://packages.guix.gnu.org/packages/python-pytorch'><img src='https://packages.guix.gnu.org/packages/python-pytorch/badges/latest-version.svg' alt='Version in GNU Guix'></a>
Example Markdown:
[](https://packages.guix.gnu.org/packages/python-pytorch)
Example Org:
[[https://packages.guix.gnu.org/packages/python-pytorch][https://packages.guix.gnu.org/packages/python-pytorch/badges/latest-version.svg]]