python-sentence-transformers
Multilingual text embeddings
This framework provides an easy method to compute dense vector representations for sentences, paragraphs, and images. The models are based on transformer networks like BERT / RoBERTa / XLM-RoBERTa and achieve state-of-the-art performance in various tasks. Text is embedded in vector space such that similar text are closer and can efficiently be found using cosine similarity.
This package provides easy access to pretrained models for more than 100 languages, fine-tuned for various use-cases.
Further, this framework allows an easy fine-tuning of custom embeddings models, to achieve maximal performance on your specific task.
- Versions: 3.0.1
- Website: https://www.SBERT.net
- Licenses: ASL 2.0
- Package source: gnu/packages/machine-learning.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of python-sentence-transformers
as follows:
guix install python-sentence-transformers
Or install a particular version:
guix install python-sentence-transformers@3.0.1
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.
Badge code
You can use the following badge to inform users of python-sentence-transformers about the latest version available in Guix.
Example HTML:
<a href='https://packages.guix.gnu.org/packages/python-sentence-transformers'><img src='https://packages.guix.gnu.org/packages/python-sentence-transformers/badges/latest-version.svg' alt='Version in GNU Guix'></a>
Example Markdown:
[](https://packages.guix.gnu.org/packages/python-sentence-transformers)
Example Org:
[[https://packages.guix.gnu.org/packages/python-sentence-transformers][https://packages.guix.gnu.org/packages/python-sentence-transformers/badges/latest-version.svg]]