r-collapse
Advanced and fast data transformation
This is a C/C++ based package for advanced data transformation and statistical computing in R that is extremely fast, class-agnostic, robust and programmer friendly. Core functionality includes a rich set of S3 generic grouped and weighted statistical functions for vectors, matrices and data frames, which provide efficient low-level vectorizations, OpenMP
multithreading, and skip missing values by default. These are integrated with fast grouping and ordering algorithms (also callable from C), and efficient data manipulation functions. The package also provides a flexible and rigorous approach to time series and panel data in R. It further includes fast functions for common statistical procedures, detailed (grouped, weighted) summary statistics, powerful tools to work with nested data, fast data object conversions, functions for memory efficient R programming, and helpers to effectively deal with variable labels, attributes, and missing data.
- Versions: 2.0.19
- Website: https://sebkrantz.github.io/collapse/
- Licenses: GPL 2+
- Package source: gnu/packages/cran.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of r-collapse
as follows:
guix install r-collapse
Or install a particular version:
guix install r-collapse@2.0.19
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.
Badge code
You can use the following badge to inform users of r-collapse about the latest version available in Guix.
Example HTML:
<a href='https://packages.guix.gnu.org/packages/r-collapse'><img src='https://packages.guix.gnu.org/packages/r-collapse/badges/latest-version.svg' alt='Version in GNU Guix'></a>
Example Markdown:
[](https://packages.guix.gnu.org/packages/r-collapse)
Example Org:
[[https://packages.guix.gnu.org/packages/r-collapse][https://packages.guix.gnu.org/packages/r-collapse/badges/latest-version.svg]]