r-fastmap
Fast implementation of a key-value store
This package provides a fast implementation of a key-value store. Environments are commonly used as key-value stores, but every time a new key is used, it is added to R's global symbol table, causing a small amount of memory leakage. This can be problematic in cases where many different keys are used. Fastmap avoids this memory leak issue by implementing the map using data structures in C++.
- Versions: 1.2.0
- Website: https://r-lib.github.io/fastmap/
- Licenses: Expat
- Package source: gnu/packages/cran.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of r-fastmap
as follows:
guix install r-fastmap
Or install a particular version:
guix install r-fastmap@1.2.0
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.
Badge code
You can use the following badge to inform users of r-fastmap about the latest version available in Guix.
Example HTML:
<a href='https://packages.guix.gnu.org/packages/r-fastmap'><img src='https://packages.guix.gnu.org/packages/r-fastmap/badges/latest-version.svg' alt='Version in GNU Guix'></a>
Example Markdown:
[](https://packages.guix.gnu.org/packages/r-fastmap)
Example Org:
[[https://packages.guix.gnu.org/packages/r-fastmap][https://packages.guix.gnu.org/packages/r-fastmap/badges/latest-version.svg]]