r-rcppparallel
Parallel programming tools for Rcpp
This package provides high level functions for parallel programming with Rcpp. For example, the parallelFor()
function can be used to convert the work of a standard serial for
loop into a parallel one and the parallelReduce()
function can be used for accumulating aggregates or other values.
- Versions: 5.1.10
- Website: https://rcppcore.github.io/RcppParallel/
- Licenses: GPL 2
- Package source: gnu/packages/cran.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of r-rcppparallel
as follows:
guix install r-rcppparallel
Or install a particular version:
guix install r-rcppparallel@5.1.10
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.
Badge code
You can use the following badge to inform users of r-rcppparallel about the latest version available in Guix.
Example HTML:
<a href='https://packages.guix.gnu.org/packages/r-rcppparallel'><img src='https://packages.guix.gnu.org/packages/r-rcppparallel/badges/latest-version.svg' alt='Version in GNU Guix'></a>
Example Markdown:
[](https://packages.guix.gnu.org/packages/r-rcppparallel)
Example Org:
[[https://packages.guix.gnu.org/packages/r-rcppparallel][https://packages.guix.gnu.org/packages/r-rcppparallel/badges/latest-version.svg]]