rust-blake3
BLAKE3 hash function Rust implementation
This crate provides the official Rust implementation of the BLAKE3 cryptographic hash function. BLAKE3 is faster than MD5, SHA-1, SHA-2, SHA-3, and BLAKE2.
- Versions: 1.5.5 · 0.3.8
- Website: https://github.com/BLAKE3-team/BLAKE3
- Licenses: ASL 2.0 · CC0
- Package source: gnu/packages/crypto.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of rust-blake3
as follows:
guix install rust-blake3
Or install a particular version:
guix install rust-blake3@0.3.8
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.
Badge code
You can use the following badge to inform users of rust-blake3 about the latest version available in Guix.
Example HTML:
<a href='https://packages.guix.gnu.org/packages/rust-blake3'><img src='https://packages.guix.gnu.org/packages/rust-blake3/badges/latest-version.svg' alt='Version in GNU Guix'></a>
Example Markdown:
[![Version in GNU Guix](https://packages.guix.gnu.org/packages/rust-blake3/badges/latest-version.svg)](https://packages.guix.gnu.org/packages/rust-blake3)
Example Org:
[[https://packages.guix.gnu.org/packages/rust-blake3][https://packages.guix.gnu.org/packages/rust-blake3/badges/latest-version.svg]]