This package browser is in early development. Mind the rough edges.

rust-chacha20

ChaCha20 stream cipher implemented in pure Rust

The ChaCha20 stream cipher (RFC 8439) implemented in pure Rust using traits from the RustCrypto cipher crate, with optional architecture-specific hardware acceleration (AVX2, SSE2). Additionally provides the ChaCha8, ChaCha12, XChaCha20, XChaCha12 and XChaCha8 stream ciphers, and also optional rand_core-compatible RNGs based on those ciphers.

Installation

Install the latest version of rust-chacha20 as follows:

guix install rust-chacha20

Or install a particular version:

guix install rust-chacha20@0.8.1

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.