This package browser is in early development. Mind the rough edges.

rust-peeking-take-while

Provides the peeking_take_while iterator adaptor method

Like Iterator::take_while, but calls the predicate on a peeked value. This allows you to use Iterator::by_ref and Iterator::take_while together, and still get the first value for which the take_while predicate returned false after dropping the by_ref.

Installation

Install the latest version of rust-peeking-take-while as follows:

guix install rust-peeking-take-while

Or install a particular version:

guix install rust-peeking-take-while@0.1.2

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.