rust-strsim
Rust implementations of string similarity metrics
This crate includes implementations of string similarity metrics. It includes Hamming, Levenshtein, OSA, Damerau-Levenshtein, Jaro, and Jaro-Winkler.
- Versions: 0.9.3 · 0.8.0 · 0.7.0 · 0.6.0 · 0.5.2 · 0.11.1 · 0.10.0
- Website: https://github.com/rapidfuzz/strsim-rs
- Licenses: Expat
- Package source: gnu/packages/crates-io.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of rust-strsim
as follows:
guix install rust-strsim
Or install a particular version:
guix install rust-strsim@0.10.0
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.
Badge code
You can use the following badge to inform users of rust-strsim about the latest version available in Guix.
Example HTML:
<a href='https://packages.guix.gnu.org/packages/rust-strsim'><img src='https://packages.guix.gnu.org/packages/rust-strsim/badges/latest-version.svg' alt='Version in GNU Guix'></a>
Example Markdown:
[](https://packages.guix.gnu.org/packages/rust-strsim)
Example Org:
[[https://packages.guix.gnu.org/packages/rust-strsim][https://packages.guix.gnu.org/packages/rust-strsim/badges/latest-version.svg]]