This package browser is in early development. Mind the rough edges.

sdsl-lite

Succinct data structure library

The Succinct Data Structure Library (SDSL) is a powerful and flexible C++11 library implementing succinct data structures. In total, the library contains the highlights of 40 research publications. Succinct data structures can represent an object (such as a bitvector or a tree) in space close to the information-theoretic lower bound of the object while supporting operations of the original object efficiently. The theoretical time complexity of an operation performed on the classical data structure and the equivalent succinct data structure are (most of the time) identical.

Installation

Install the latest version of sdsl-lite as follows:

guix install sdsl-lite

Or install a particular version:

guix install sdsl-lite@2.1.1

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.

Badge code

You can use the following badge to inform users of sdsl-lite about the latest version available in Guix.

Example HTML:

<a href='https://packages.guix.gnu.org/packages/sdsl-lite'><img src='https://packages.guix.gnu.org/packages/sdsl-lite/badges/latest-version.svg' alt='Version in GNU Guix'></a>

Example Markdown:

[![Version in GNU Guix](https://packages.guix.gnu.org/packages/sdsl-lite/badges/latest-version.svg)](https://packages.guix.gnu.org/packages/sdsl-lite)

Example Org:

[[https://packages.guix.gnu.org/packages/sdsl-lite][https://packages.guix.gnu.org/packages/sdsl-lite/badges/latest-version.svg]]