sicp
Structure and Interpretation of Computer Programs
Structure and Interpretation of Computer Programs (SICP) is a textbook aiming to teach the principles of computer programming.
Using Scheme, a dialect of the Lisp programming language, the book explains core computer science concepts such as abstraction in programming, metalinguistic abstraction, recursion, interpreters, and modular programming.
- Versions: 20180718-3.bda03f7
- Website: https://sarabander.github.io/sicp
- Licenses: CC-BY-SA 4.0
- Package source: gnu/packages/scheme.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of sicp
as follows:
guix install sicp
Or install a particular version:
guix install sicp@20180718-3.bda03f7
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.
Badge code
You can use the following badge to inform users of sicp about the latest version available in Guix.
Example HTML:
<a href='https://packages.guix.gnu.org/packages/sicp'><img src='https://packages.guix.gnu.org/packages/sicp/badges/latest-version.svg' alt='Version in GNU Guix'></a>
Example Markdown:
[![Version in GNU Guix](https://packages.guix.gnu.org/packages/sicp/badges/latest-version.svg)](https://packages.guix.gnu.org/packages/sicp)
Example Org:
[[https://packages.guix.gnu.org/packages/sicp][https://packages.guix.gnu.org/packages/sicp/badges/latest-version.svg]]