treefmt
Command-line application to format the code tree
This application provides a way to unify the formatting process of the codebase. It is nice for large code trees where using multiple formatters are common. treefmt
comes with the following features.
Unified CLI and output.
Runs formatters in parallel.
Cache changed files for performance.
The application does have some design decisions to keep in mind.
The source code is kept under version control, making it possible to revert and check changes.
Only one formatter per file, making outputs idempotent.
- Versions: 0.6.1
- Website: https://numtide.github.io/treefmt
- Licenses: Expat
- Package source: gnu/packages/rust-apps.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of treefmt
as follows:
guix install treefmt
Or install a particular version:
guix install treefmt@0.6.1
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.
Badge code
You can use the following badge to inform users of treefmt about the latest version available in Guix.
Example HTML:
<a href='https://packages.guix.gnu.org/packages/treefmt'><img src='https://packages.guix.gnu.org/packages/treefmt/badges/latest-version.svg' alt='Version in GNU Guix'></a>
Example Markdown:
[](https://packages.guix.gnu.org/packages/treefmt)
Example Org:
[[https://packages.guix.gnu.org/packages/treefmt][https://packages.guix.gnu.org/packages/treefmt/badges/latest-version.svg]]